Cozeva Maintenance

Incident Report for Cozeva

Resolved

This incident has been resolved.
Posted Jun 14, 2026 - 04:13 EDT

Update

We are continuing to investigate this issue.
Posted Jun 14, 2026 - 04:11 EDT

Investigating

Cozeva Unavailable for the next 4 hours
Posted Jun 14, 2026 - 01:31 EDT
This incident affected: Cozeva UI and SFTP Feeds.